Skip to content
Blog

n8n AI/LLM Node Security Bypass (CVE-2026-72771) — High Severity

N8N-Banner-ucartz
In this article
  1. Understanding the n8n AI/LLM Node Security Bypass
  2. CVE Details
  3. Affected Products
  4. Current Status
  5. Severity Level
  6. Possible Solutions
  7. References

Understanding the n8n AI/LLM Node Security Bypass

A significant security flaw has been discovered in n8n, an open-source workflow automation tool. This vulnerability, identified as CVE-2026-72771, allows low-privileged users to bypass critical security measures, potentially leading to the theft of sensitive credentials. It affects how n8n handles connections within its AI and Large Language Model (LLM) nodes, putting shared secrets at risk.

CVE Details

Product: n8n

Published: August 11, 2026

Severity: High (CVSS Score: 7.1)

Status: Analyzed

Affected Products

This vulnerability impacts n8n Community and Enterprise editions. Specifically, all versions of n8n prior to 2.31.5 and 2.32.1 are at risk. Users running any version before these patched releases should take immediate action.

Current Status

The vulnerability has been thoroughly analyzed, and the details, including potential impacts and solutions, are publicly available. This allows users to understand the risk and apply necessary fixes.

Severity Level

Rated as “High” severity with a CVSS score of 7.1, this vulnerability poses a serious threat. The ability for a low-privileged workflow editor to exfiltrate sensitive credentials means that an attacker could gain unauthorized access to underlying services connected to n8n. This could lead to data breaches, unauthorized operations, and further compromise of your systems. While user interaction is not required by the attacker for exploitation, it does rely on the attacker having low-privileged access to workflow editing and shared credentials.

Possible Solutions

The good news is that n8n has already released patches to address this critical flaw. Users are strongly advised to update their installations without delay:

  • Upgrade to n8n version 2.31.5 or later.
  • Upgrade to n8n version 2.32.1 or later.

If an immediate upgrade isn’t feasible, temporary mitigation steps can help reduce the risk, though they do not fully eliminate it:

  • Ensure that only fully trusted users have permissions to create and edit workflows.
  • Strictly limit the sharing of credentials to only those users who are absolutely trusted.
  • Conduct regular audits of credentials with domain restrictions to identify and rectify any unexpected sharing arrangements.

These workarounds should be considered short-term measures while you plan and execute your upgrade to a patched version.

References

https://github.com/n8n-io/n8n/security/advisories/GHSA-64xh-79j6-r5v8

https://www.vulncheck.com/advisories/n8n-before-credential-restriction-bypass-via-ai-llm-nodes

Share
Alex Joseph

Alex Joseph

Alex Joseph is a Senior Support Staff professional with deep experience in server management, web hosting technologies, and cybersecurity operations. He works daily with Linux servers, cloud platforms, performance tuning, and security hardening, giving him strong real-world technical knowledge. Along with his support role, he write about security best practices, hosting infrastructure, and software management.

Related updates

Start Building Today

Ready to Get Started?

VPS, dedicated servers, streaming and managed hosting with 24/7 support from the Ucartz team.