Skip to content
Blog

Joomla! Cross-Site Scripting Vulnerability (CVE-2026-73336) — Medium Severity

Joomla-Banner-Ucartz
In this article
  1. Understanding the Joomla! Cross-Site Scripting Vulnerability
  2. CVE Details
  3. Affected Products
  4. Current Status
  5. Severity Level
  6. Possible Solutions
  7. References

Understanding the Joomla! Cross-Site Scripting Vulnerability

A security flaw has been found in Joomla!, a popular content management system. This issue, identified as a Cross-Site Scripting (XSS) vulnerability, could allow attackers to inject harmful scripts into websites running affected Joomla! versions. The problem specifically arises from how Joomla! handles “schema.org” outputs, which are used to help search engines understand website content better. Incorrect handling of certain characters or flags in these outputs creates an opening for malicious code to be executed in a user’s browser.

CVE Details

  • Product: Joomla!
  • Published: August 18, 2026
  • Severity: Medium
  • Status: Analyzed

Affected Products

This vulnerability impacts specific versions of the Joomla! CMS:

  • Joomla! 5.1.0 through 5.4.7
  • Joomla! 6.0.0 through 6.1.2

Users running these versions should take immediate action to protect their websites.

Current Status

The vulnerability (CVE-2026-73336) has been officially analyzed. This means that its details are publicly available, and a solution has been provided by the Joomla! project team. It’s crucial for website administrators to be aware of this status and apply the recommended fixes promptly.

Severity Level

Rated as “Medium” severity, this Cross-Site Scripting vulnerability could allow an attacker to execute arbitrary script code in the context of the user’s browser. This often means an attacker could steal session cookies, deface the website, redirect users to malicious sites, or perform actions on behalf of the logged-in user. While not always leading to full system compromise, XSS vulnerabilities can significantly impact user trust and data integrity.

Possible Solutions

Joomla! has released updates to address this XSS vulnerability. To secure your Joomla! installation, it is strongly recommended to upgrade to one of the following patched versions:

  • Upgrade to Joomla! version 5.4.8
  • Upgrade to Joomla! version 6.1.3

Regularly updating your CMS and its components is a fundamental cybersecurity practice to mitigate known vulnerabilities.

References

https://developer.joomla.org/security-centre/1073-20260806-core-xss-through-schema-org-outputs.html

https://www.joomla.org/

Share
Alex Joseph

Alex Joseph

Alex Joseph is a Senior Support Staff professional with deep experience in server management, web hosting technologies, and cybersecurity operations. He works daily with Linux servers, cloud platforms, performance tuning, and security hardening, giving him strong real-world technical knowledge. Along with his support role, he write about security best practices, hosting infrastructure, and software management.

Related updates

Start Building Today

Ready to Get Started?

VPS, dedicated servers, streaming and managed hosting with 24/7 support from the Ucartz team.